[Solución] Problemas con ALFA-AWUS036H en Lucid Lynx

>

Acabo de actualizar mi ultimo equipo a Lucid Lynx. Como sabemos es la ultima edición de Ubuntu Linux. Bien, me acabo de llevar una desagradable sorpresa. Mi ALFA-AWUS036H se niega a funcionar. Es reconocida por Ubuntu pero aparece el mensaje de “el dispositivo no está listo”.
Lo que me llama la atención es que tanto en las Beta como en la instalación Virtualizada de la versión final si me funcionaba. En fin que algo debe de haber en mi Pc que no le gusta. Pero funcionaba perfectamente en Karmic.

alfa - awus036hLas primeras pruebas fueron las habituales. Conecta y desconecta, prueba en otro puerto, descarga el modulo rtl8187 y volver a cargarlo. Nada, no funcionaba. Lo curioso es que sí lo hace en el resto de equipos.

Ya apunto de golpearme la cabeza contra un piano. He dado con una solución que por el momento ha funcionado.

Desde terminal seguimos los siguientes pasos.
1. sudo rmmod r8187 rtl8187 mac80211 cfg80211
2. sudo mkdir /usr/src/drivers
3. cd /usr/src/drivers
4. sudo wget http://dl.aircrack-ng.org/drivers/rtl8187_linux_26.1010.zip
5. sudo unzip rtl8187_linux_26.1010.zip
6. cd rtl8187_linux_26.1010.0622.2006/
7. sudo wget http://patches.aircrack-ng.org/rtl8187_2.6.27.patch
8. sudo wget http://patches.aircrack-ng.org/rtl8187_2.6.32.patch
9. sudo tar xzf drv.tar.gz
10. sudo tar xzf stack.tar.gz
11. sudo patch -Np1 -i rtl8187_2.6.27.patch
12. sudo patch -Np1 -i rtl8187_2.6.32.patch
13. sudo make
14. sudo make install
15. sudo modprobe r8187

Y perfecto, al conectar el dispositivo a la primera comenzó a dar señales de vida.
Comparte esta entrada: