Paquetes básicos luego de instalar Ubuntu 14.04 LTS Trusty Tahr

Seguramente muchos ya tienen la ultima versión de Ubuntu 14.04 LTS y les vamos a compartir algunos paquetes básicos y útiles para después de una instalación, como multimedia, editores gráficos, codecs, fuentes y otros. También pueden dar un pequeño paseo por Ubuntu Trusty desde el navegador, accediendo desde: http://www.ubuntu.com/tour/.

 

1. Preliminares:

Una de las primeras cosas que hago justo después de instalar una versión de Ubuntu y conectarme a Internet es actualizar los paquetes disponibles:

sudo apt-get update && sudo apt-get upgrade

También podemos hacer esto a través del gestor de actualizaciones, pero sigo prefiriendo la consola. Es mucho mas ágil para estas cosas. Puede suceder que aparezca e mensaje “No se pudo bloquear /var/lib/apt/lists/lock – open (11 Recurso temporalmente no disponible)”, la solución en ese caso es escribir en terminal: sudo rm /var/lib/apt/lists/lock y luego sudo apt-get update. No es una solución muy limpia pero nos ayudará a salir del paso.

Hoy por hoy el Centro de Software de Ubuntu está más que maduro. Sin embargo prefiero Synaptic, pues me parece, con diferencia, mucho más ligero que éste. Creo que junto con Aptitude, Synaptic se merece la gran cantidad de fans que tiene. Además me paso el día cambiando constantemente de Ubuntu, Debian a Mint por lo que es buena idea usar al viejo Synaptic y no perder la costumbre: sudo apt-get install synaptic

2. Paquetes básicos

Un paquete muy bueno que nos permite tener una mejor experiencia a la hora de instalar paquetes es aptitude, tecleamos en la terminal lo siguiente:

sudo apt-get install aptitude

Ahora instalamos el paquete que nos instala paquetes esenciales:

sudo aptitude install build-essential

Extras restringidos de ubuntu, es software esencial, pero que no viene instalado por defeecto debido a los derechos de autor y parecidos, cuando realizamos a instalación de la distro se pregunta si queremos instalarla. Este contiene software para:

  • Soporte de archivos mp3 y para reproducir DVD.
  • Fuentes de Microsoft
  • Plugin Flash
  • Codecs de video y audio

sudo aptitude install ubuntu-restricted-extras

En la pagina oficial de paquete podemos encontrar más información: https://help.ubuntu.com/community/RestrictedFormats y también esta disponible para otros sabores como kubuntu, xubuntu, lubuntu.

Estos son algunos codecs que pueden faltar:

 sudo apt-get install faad gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-pitfdll

Soporte a los formatos de compresión más populares.

sudo apt-get install p7zip-rar p7zip-full unace unrar zip unzip sharutils rar uudeview mpack arj cabextract file-roller

3. Paquetes multimedia

Reproductor VLC:

sudo apt-get install vlc

Pitivi, editor de videos:

sudo aptitude install pitivi

Leer e-books:

sudo apt-get install calibre

4. Paquetes de ofimática

El paquete LibreOffice ya viene pre-instalado, pero podemos instalar algunos un poco más ligeros y libres, como Abiword, que nos permite editar textos y activando un plugin podemos realizar colaboraciones entre varias personas, el plugin se llama Abicollab, instalando el paquete podemos utilizar nuestra cuenta:

sudo apt-get install abiword

Editor de hoja de cálculo:

sudo apt-get install gnumeric

5. Paquetes Internet

Cliente IRC:

sudo apt-get install xchat

Pidgin para mensajería:

sudo apt-get install pidgin

El navegador web chromium:

sudo apt-get install chromium-browser

Para descargar torrents, podemos utilizar transmission o Deluge

sudo apt-get install transmission

sudo apt-get install deluge-torrent

6. Paquetes edición gráfica

Gimp:

sudo apt-get install gimp

Inkscape para vectores:

sudo apt-get install inkscape

Para gráficos en 3D, blender:

sudo apt-get install blender

Esta es una pequeña lista de programas básicos que se pueden instalar en Ubuntu 14.04 LTS, se pueden agregar otros más con el paso de los días y pueden compartir en los comentarios los paquetes que instalarían después de una instalación, servirá de mucho 🙂

Comparte esta entrada:

Acerca de Joshua Laister

En los blogs desde hace unos años (2007), compartiendo lo que me gusta y creo que es interesante para los demás. Cuando sea grande pienso ser un jedi y sigo aprendiendo como buen padawan.

  • SAYO

    En Webup8 hicieron un post con consejos interesantes
    http://www.webupd8.org/2014/04/10-things-to-do-after-installing-ubuntu.html

  • apana8

    Entre os programas torrent engadiría o qbittorrent.

  • Leonardo Daniel Santiago Garci

    sudo apt-get install faad gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad
    gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly
    gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-pitfdll

    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    El paquete gstreamer0.10-plugins-ugly-multiverse no está disponible, pero algún otro paquete hace referencia
    a él. Esto puede significar que el paquete falta, está obsoleto o solo se
    encuentra disponible desde alguna otro origen

    El paquete gstreamer0.10-ffmpeg no está disponible, pero algún otro paquete hace referencia
    a él. Esto puede significar que el paquete falta, está obsoleto o solo se
    encuentra disponible desde alguna otro origen

    E: El paquete «gstreamer0.10-ffmpeg» no tiene un candidato para la instalación
    E: El paquete «gstreamer0.10-plugins-ugly-multiverse» no tiene un candidato para la instalación
    E: No se ha podido localizar el paquete gstreamer0.10-pitfdll
    E: No se pudo encontrar ningún paquete con la expresión regular «gstreamer0.10-pitfdll»

    Parece que muchos paquetes no están en los repositorios

  • Diego

    Hola, esta guia sirve para Ubuntu Gnome? perdon pero no soy un experto en linux. Gracias.

  • JC

    He conseguido que funcionen los mp3. Aunque si pones “sudo apt-get install faad gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad
    gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly
    gstreamer0.10-plugins-ugly-multiverse gstreamer0.10-pitfdll”
    dice:
    ” El paquete «gstreamer0.10-ffmpeg» no tiene un candidato para la instalación
    E: El paquete «gstreamer0.10-plugins-ugly-multiverse» no tiene un candidato para la instalación
    E: No se ha podido localizar el paquete gstreamer0.10-pitfdll
    E: No se pudo encontrar ningún paquete con la expresión regular «gstreamer0.10-pitfdll»”

    PERO AHORA ESCUCHO ,POR FIN , los mp3

    GRACIAS

  • David

    Para gente muy novata en esto pero quiere un linux libre de virus y rápido en su PC:

    http://informaticonoob.blogspot.com.es/

  • aitorito

    Algunos muy útiles para mí:

    JOIN AUDIO & VIDEO
    sudo apt-get install transcode
    ejemplo: avimerge -o preba_con_sonido.avi -i prueba.avi -p 1.mp3

    RECORD AUDIO IN MP3 audio-recorder
    sudo apt-add-repository ppa:osmoma/audio-recorder
    sudo apt-get update && sudo apt-get install audio-recorder

    INSTALL KOLOURPAINT (el mas parecido al paint de windows)
    sudo apt-get install kolourpaint4

    INSTALL SUBLIME (editor de texto muy completo)
    sudo add-apt-repository ppa:webupd8team/sublime-text-3
    sudo apt-get update
    sudo apt-get install sublime-text-installer

    INSTALL SIMPLESCREENRECORDER VIDEO (graba audio y video comprimido de lo que vemos en pantalla)
    sudo add-apt-repository ppa:maarten-baert/simplescreenrecorder
    sudo apt-get update
    sudo apt-get install simplescreenrecorder
    sudo apt-get install ubuntu-restricted-extras

  • aitorito

    Algunos muy útiles para mí:

    JOIN AUDIO & VIDEO
    sudo apt-get install transcode
    ejemplo: avimerge -o preba_con_sonido.avi -i prueba.avi -p 1.mp3

    RECORD AUDIO IN MP3 audio-recorder
    sudo apt-add-repository ppa:osmoma/audio-recorder
    sudo apt-get update && sudo apt-get install audio-recorder

    INSTALL KOLOURPAINT (el mas parecido al paint de windows)
    sudo apt-get install kolourpaint4

    INSTALL SUBLIME (editor de texto muy completo)
    sudo add-apt-repository ppa:webupd8team/sublime-text-3
    sudo apt-get update
    sudo apt-get install sublime-text-installer

    INSTALL SIMPLESCREENRECORDER VIDEO (graba audio y video comprimido de lo que vemos en pantalla)
    sudo add-apt-repository ppa:maarten-baert/simplescreenrecorder
    sudo apt-get update
    sudo apt-get install simplescreenrecorder
    sudo apt-get install ubuntu-restricted-extras

  • Paul Kelsey

    Excelente consejo! me estoy iniciando en ubuntu, y antes odiaba mucho a linux, ahora me estoy familiarizando, tengo arranque dual windows-ubuntu 14 pero, me doy cuenta que lamentablemente la compatibilidad de hardware es menor, pero la calidad de navegacion por internet es mayor 🙂

    • jamesjon

      Aquí te dejo un repositorio, que permite instalar drivers de nvidia, ati, y intel en su ultima version.

      sudo apt-add-repository ppa:xorg-edgers/ppa –yes

      Y aquí para añadir compatibilidad con pendrives wifi entre otras muchas cosas.

      sudo apt-get install linux-firmware-nonfree

      Pruebalo 😉 saludos

  • patomonono

    ?Donde pongo esto y cual es la consola? sudo apt-get update && sudo apt-get upgrade
    Perdon por las faltas, nome sale el acento y signo de interrogacion.

  • patomonono

    ?Donde pongo esto y cual es la consola? sudo apt-get update && sudo apt-get upgrade
    Perdon por las faltas, nome sale el acento y signo de interrogacion.

  • rama

    Hola, que tal 🙂
    A mi me pasa que hago:

    cd Descargas
    tar zxf utserver.tar.gz
    despues lo levanto:
    ./utorrent-server-alpha-v3_3/utserver

    introdusco la url en el navegador:
    localhost:8080/gui/

    usu: admin , sin pass

    pero me queda la ventana en blanco :s

  • Ayoamaro
  • Ayoamaro