Cómo saber si tu Linux es vulnerable a los fallos de seguridad Meltdown y Spectre

Si usas un PC compatible con procesador Intel es casi un 90% probable que sea vulnerable a los fallos de seguridad Meltdown y Spectre. Puedes consultar la lista de procesadores afectados aquí pero si todavía tienes dudas o quieres asegurarte de que una vez aplicado los parches de seguridad realmente tu sistema está seguro puedes probar a correr el script meltdown-checker. Para ello debes seguir los siguientes pasos:

  1. Descargar el script:
    wget https://raw.githubusercontent.com/speed47/spectre-meltdown-checker/master/spectre-meltdown-checker.sh
  2. Corremos el script: sudo sh spectre-meltdown-checker.sh

Si todo es correcto se ejecutarán una serie de pruebas y en poco menos de un minuto tendremos la respuesta a nuestras dudas. :S

 

Comparte esta entrada:

Acerca de Miguel Parada

Curioso, me gusta saber cómo funcionan las cosas. Knowmad, Desarrollador Web, #Marketing digital, #socialmedia. HTML, #PHP, #JavaScript, jQuery, CSS y el editor mis herramientas. Uso #Linux ;)

  • kj

    Vi en otro sitio este otro código y me pareció bastante bueno:

    dmesg | grep “Kernel/User page tables isolation: enabled” &&
    echo “Bien! Estás parcheado! :)” || echo “Aún no has recibido la
    actualización del kernel :(”

    kj

    • Miguel Parada

      Interesante. Gracias Kj!